fbpx
Minuty czytania: 2

Poznaj funkcję JEŻELI

Funkcja JEŻELI to z pewnością jedna z najpopularniejszych i najbardziej przydatnych funkcji. Zawsze powtarzam, że gdybym miał się nauczyć ich tylko dwóch, to byłyby to właśnie: JEŻELI [ang. IF] i WYSZUKAJ.PIONOWO [ang. VLOOKUP]

Funkcja JEŻELI excel: znaki-prawda-fałsz

Do czego służy funkcja JEŻELI w Excel?

Mówiąc językiem Excela, funkcja JEŻELI pozwala na sprawdzenie jakiegoś warunku, zwanego testem logicznym i decyzję:

  • co ma się wydarzyć, jeżeli warunek jest prawdziwy,
  • co ma się wydarzyć, jeżeli warunek jest nieprawdziwy.

Aby łatwiej zrozumieć jej działanie, weźmy przykład z „normalnego” życia. Na przykład, chcesz iść na spacer i zastanawiasz się czy założyć czapkę. Zazwyczaj nie zakładasz jej, jeżeli temperatura nie spada poniżej zera. Jednakże, spoglądasz na termometr, a tam -5 stopni. Wypada założyć 🙂

Właśnie przeprowadziłeś test logiczny za pomocą funkcji JEŻELI. Moglibyśmy to zapisać tak:

=JEŻELI(temperatura < 0 stopni;założę czapkę;nie zakładam czapki)
=Funkcja(twój warunek;co zrobisz jeżeli warunek jest prawdziwy;co zrobisz jeżeli warunek jest fałszywy)

Myślę, że chwytasz o co w tym chodzi. Czas przejść do języka Excela.

Jak to działa?

Całość zapisujemy tak:

=JEŻELI(test_logiczny;[wartość_jeżeli_prawda];[wartość_jeżeli_fałsz])

Powiedzmy, że w masz taką sytuację:

Plan vs. realizacja - zastosowanie funkcji Jeżeli

W komórce A2 jest plan sprzedaży, w komórce B2 będziesz uzupełniał realizację tego planu. Chciałbyś, aby w komórce C2 automatycznie, na podstawie podanych wcześniej wartości wyliczana była wartość premii. Dla uproszczenia przyjmijmy, że:

  1. za realizację na poziomie co najmniej 100%, należy się premia 500 zł,
  2. za realizację na poziomie niższym niż 100%, premia się nie należy.

Jak to zapisać, żeby Excel nas zrozumiał?

Funkcja Jeżeli Excel - przykład formuły

W komórce C2, wpisujemy:

=JEŻELI(B2>=A2;500;0)

Tym samym „mówimy Excelowi” – jeżeli wartość w komórce B2 jest większa równa (większa bądź równa) niż wartość w komórce A2 to podaj wartość 500; a jeżeli nie jest (większa bądź równa) to podaj wartość 0.

Użyliśmy tu tak tzw. operatorów większości, mniejszości, równości. Więcej o nich, napiszę pewnie w jednym z kolejnych wpisów.

Funkcja Jeżeli Excel - zastosowanie w sprawdzaniu realizacji planów

Plik z gotową formułą.


Chcesz lepiej poznać Excela? Zapisz się na Excelness News


Funkcja JEŻELI Excel: praktyczne zastosowanie

Tych jest całe mnóstwo. Właśnie dlatego funkcja JEŻELI jest tak popularna. Dzięki niej możesz bowiem „sterować wydarzeniami” czy też wpływać na to co zobaczą odbiorcy Twoich plików, na przykład w zależności od tego co wpiszą w określone komórki.

Dzięki połączeniu JEŻELI z innymi funkcjami czy narzędziami (np. formatowaniem warunkowym) zyskujesz naprawdę potężne możliwości i sprawiasz, że Twoje arkusze są bardziej interaktywne.

Jeżeli chciałbyś poznać więcej praktycznych zastosowań tej funkcji, koniecznie daj mi znać w komentarzu. Napisz także, jeżeli uda Ci się wykorzystać w praktyce powyższą wiedzę.


Masz problemy z Excelem? Uzyskaj pomoc na grupie Keep Calm And Use Excel.


2 Komentarze

Mary · 9 października 2018 o 07:47

K9mpletnie nie znam się na Excelu. Dzięki za te wpisy, próbuje to ogarniać. Pytanie blondynki: te kolorki są tylko dla przykładu? Nic nie muszę tak zaznaczać?

    admin · 9 października 2018 o 07:51

    Mary, dzięki za komentarz. Dokładnie, to tylko przykład i wyróżnienie poszczególnych argumentów. W razie wątpliwości – pytaj śmiało 😉

Dodaj komentarz

Twój adres email nie zostanie opublikowany. Pola, których wypełnienie jest wymagane, są oznaczone symbolem *