fbpx

Funkcja LUB

Funkcja LUB

Funkcja LUB [Ang: OR] sprawdza podane przez Ciebie warunki i w rezultacie daje wartość PRAWDA albo FAŁSZ.

Rozdroże. Wybór dróg.

Jak działa?

Każdy ze sprawdzanych warunków także daje wartość PRAWDA albo FAŁSZ. Powiedzmy, że warunek – sprawdzamy płeć osoby – wygląda tak:

=A2="K"

czyli, sprawdzamy czy w komórce A2, znajduje się litera K, która to reprezentuje kobietę. I tak:

  • Jeżeli w komórce A2 będzie litera K, w wyniku otrzymasz wartość PRAWDA.
  • Jeżeli będzie wartość inna niż K, w wyniku otrzymasz FAŁSZ.

Z kolei w kolejnej komórce sprawdzamy wiek:

=B2>30

co oznacza, sprawdzenie czy dana osoba ma więcej niż 30 lat.

I podobnie:

  • Jeżeli w komórce B2 będzie wartość większa niż 30, w wyniku otrzymasz wartość PRAWDA.
  • Jeżeli będzie wartość mniejsza lub równa, w wyniku otrzymasz FAŁSZ.

Funkcję LUB wykorzystujesz właśnie w sytuacji, w której masz do sprawdzenia wiele warunków. Powiedzmy, że chcesz sprawdzić (dość abstrakcyjny) zestaw warunków:

Szukasz przypadków, kiedy dana osoba jest kobietą lub ma więcej niż 30 lat. Zapiszesz to tak:

=LUB(A2="K";B2>30)

Funkcja LUB działa w ten sposób, że jeżeli przynajmniej jeden z warunków jest prawdziwy, to całe wyrażenie jest prawdziwe. A zatem, aby funkcja LUB dała w wyniku FAŁSZ – wszystkie warunki muszą być fałszywe.

Jak działa funkcja LUB

Składnia i argumenty

Składnia jest bardzo prosta. To nazwa funkcji i kolejne warunki. Warunków może być maksymalnie…255.

=LUB(logiczna1;logiczna2;...;logicznaN)
=LUB(pierwsza wartość logiczna, którą 
sprawdzasz; druga wartość logiczna;...;
i kolejne)

Przykład użycia z użyciem funkcji JEŻELI

Funkcje logiczne, takie jak funkcja LUB bardzo często występują w połączeniu z funkcją JEŻELI. Dlatego, że po sprawdzeniu określonych warunków najczęściej chciałbyś, aby w wyniku tej kontroli coś się wydarzyło – czytaj pojawiło się jakieś inne działanie albo wynik.

Powiedzmy, że liczysz premie dla handlowców. Warunki premiowe są następujące: każdy dostaje 500 zł premii, jeżeli: sprzedaż (wartość sprzedaży jest w komórce A1) przekroczy 10 000 zł, lub handlowiec pozyska 10 nowych klientów (ilość nowych klientów w komórce A2).

Wiesz już, jak sprawdzić warunki dzięki funkcji LUB:

=LUB(A1>10000;A2>10)

Jednak, aby „wypłacić premię” po spełnieniu minimum jednego z warunków, musisz dodać funkcję JEŻELI i całość będzie wyglądała tak:

=JEŻELI(LUB(A1>10000;A2>10);500;0)

Powyższa formuła sprawdza warunek (sprzedaż lub liczba nowych klientów) i jeżeli jest spełniony – daje w wyniku 500, a jeżeli nie to oczywiście 0.



Podsumowanie

Funkcje logiczne, takie jak LUB czy ORAZ to „must have” w arsenale każdego adepta Excela. W połączeniu z funkcją JEŻELI pozwalają na „sterowanie” działaniami w zależności od spełnienia określonych warunków.


Masz inne problemy z Excelem? Zapraszam Cię na grupę – Keep Calm And Use Excel na Facebooku. To miejsce, w którym pomagamy sobie nawzajem w codziennych wyzwaniach z Excelem 😉


Podobał Ci się artykuł? Podziel się z innymi

Dodaj komentarz

Twój adres email nie zostanie opublikowany. Pola, których wypełnienie jest wymagane, są oznaczone symbolem *

Facebook
Facebook
Instagram
YouTube
RSS